6 razones por las cuales tu campaña en Vicidial podría no funcionar

28 Sep

Como se ha visto, recientemente hemos tenido mucho movimiento sobre Vicidial, que es una suite open source para instalar un callcenter completo sobre Linux. Pues bien, es bastante común que dado lo complejo que resulta este sistema cometamos errores y que por lo tanto nuestras campañas de marcación predictiva no saquen llamadas al exterior. Aquí recopilo algunos de los errores más comunes al momento de hacer marcación predictiva hacia el exterior:

  • Las campañas tienen el horario incorrecto. Muchas veces, las pruebas las hacemos en las noches y movemos la hora de las llamadas para entender por que no salen. Primer paso: asegurémonos de que la hora de la campaña sea la correcta y que estemos haciendo pruebas dentro del horario REAL en que se supone que nuestras campañas deben de correr.
  • No hay leads disponibles para marcar. Asegurémonos que las listas que tenemos dadas de alta para nuestra campaña tengan leads con los status de marcación válidos. Normalmente, marcamos a los NEW (nuevos leads), NA (No Answer) y B (Busy). Si nuestra lista está llena de leads que no tienen estos status, no se marcará hacia ellos. Agreguemos los nuevos status que queramos dentro de la campaña para ser válidos de remarcarles o bien, importemos nuevos leads para reintentar la operación.
  • No hay leads en el hopper. Si mandamos llamadas demasiado rápido o tenemos muchos agentes, lo más probable es que nos agotemos el hopper realmente rápido. Lo ideal es que nuestro hopper level (a nivel de campaña) esté ubicado en al menos 2.5 veces el número de agentes que podemos tener en línea en un momento dado. Este error es fácil de encontrar ya que nos aparecen indicaciones al hacer login como agente, asi que no debería ser problema localizar de que se trata.
  • Las llamadas no están saliendo a pesar de tener agentes en línea. Esto me pasó recientemente: todos los problemas de arriba habían sido verificados, pero había 5 agentes en línea y ninguno recibía llamadas. El problema fue de que tenía yo creada una campaña de marcación automática con agentes remotos (para enviar mensajes pre-grabados) y esto ocasionó que nos termináramos la cantidad de troncales disponibles para marcar al exterior (aunque nunca se usaron). Moraleja: asegúrate que bajo System Settings, el valor de Max Vicidial Trunks sea más grande que la cantidad total de agentes que tengas en un momento dado, y en caso de que así sea, asegúrate de no tener agentes remotos activos que tengan múltiples lineas de salida activadas. Al parecer, Vicidial reserva lineas aún para los agentes remotos que no las están usando.
  • Las llamadas no enlazan: dan un timeout y la interfaz de agente se queda esperando en estado “ringing”. Comúnmente es ocasionado por enlaces digitales que NO son ISDN, como R2 modificado. Algunos proveedores dan mensajes grabados en early media audio dando grabaciones como “el número que marcó no existe”. Normalmente, una persona escucharía esto y sabría que hacer, pero un sistema piensa que la llamada nunca se contestó y por lo tanto, ocurre un timeout porque 1) nunca obtuvimos ring y 2) nunca nos contestaron. La única solución es cambiar de enlace o cambiar a marcación manual, de manera que nuestros agentes puedan catalogar por ellos mismos el estado de las llamadas.
  • Las llamadas se cortan a los pocos segundos y nunca se enlazan a los agentes. Descubrí que si en la marcación automática haces un ANSWER antes de enviar un DIAL (es decir, sin un ringing de por medio), Vicidial nunca te enlaza las llamadas y te las marca como NA (No Answer). Lo correcto es que siempre debe haber un ringing antes de que la llamada sea contestada. Con eso evitarás que se marque pero nunca comunique a los agentes.

Como siempre, habrá muchas otras cosas que puedan pasar, pero en este caso estas son las más comunes. Conforme nuestra experiencia vaya aumentando, iremos ampliando la lista.

¡Suerte!

Christian Cabrera

Soy un ingenieron en comunicaciones con especial interés en el área de voz sobre IP y tecnologías sobre información. He usado Asterisk de manera diaria desde hace más de 12 años.En el 2011 co-fundé Enlaza Comunicaciones, una empresa que se especializa en brindar servicios profesionales de consultoría sobre voz sobre IP basadas en Asterisk.

  • julio

    cuando se borra una lista de vicidial, me indicaron que queda guardada en la raiz de computadora administradora, como puedo borrar estos leads definitivamente, Gracias.

    • Si por la computadora administradora te refieres a la máquina desde la cual el administrador está accediendo, se guarda solo si la descargas. De lo contrario, al eliminar una lista la estás borrando de la base de datos y ya no estará disponible.

  • Daniel Rodriguez Hernandez

    Puedes decirme como solucionar el último punto, “Las llamadas se cortan a los pocos segundos “

    • Si el caso es como el que comento, las llamadas no deben ser contestadas inmediatamente antes de enviarlas a marcar. Sin embargo, cada caso es diferente y sería necesario analizarlo a detalle para encontrar la causa del mal funcionamiento.

  • Jose Vergara

    Hola? como puedo hacer para verificar si un numero esta correcto o no? es como una pitanza

    • Tendrías que verificar la consola para ver como está haciéndose la marcación del número en cuestión.

  • Ricardo Navarro

    Estimados, desarrollamos una aplicación que si se cumplen algunas condiciones durante el desarrollo de una campaña modifica el status de algunos registros de list, cambiando de NEW a un status que creamos nosotros, eso funciona, pero el sistema continua llamando a los registros con este nuevo status, alguien sabe que debo hacer para que esos registros modificados internamente ya no sean marcados?

  • Leidy Trujillo

    Buen Día,en la empresa en la cual laboro manejamos este predictivo (Goautodial) me podrían colaborar si de alguna forma puedo hacer que este, marque a X cantidad de números asociados a un cliente.Gracias

  • Buenos tardes/días, tengo un problema al querer cargar leads a una lista, en primer lugar no me sale la opción de mapeo, y segundo no carga ningún número en la lista, vale decir que todos los número que introduzco me salen como erróneos.
    Además las listas que anteriormente tenía todas están vacías.

    Espero puedan darme una idea de lo que está pasando.

    Saludos

    • Puede ser que haya ocurrido alguna actualización incompleta y que con ello, se hayan roto algunas de las dependencias que te permiten abrir los archivos de lists o que ahora los campos de la base de datos no correspondan. Sería el primer punto que sugeriría revisar.